Partial Outage: design time restrictions with forking and version creation
Incident Report for SAP Conversational AI
Resolved
This incident has been resolved and the platform is fully operational.
Posted Sep 26, 2020 - 00:23 CEST
Monitoring
We have identified the issue to be related to the workers responsible for forking and related operations not being able to acquire their database connection. We have fixed the issue and all design time operations should be fully functional again. We are monitoring the system for stability and will conduct a detailed root cause analysis to prevent related issues in the future.
Posted Sep 25, 2020 - 23:57 CEST
Update
We are continuing the investigation with the issue suspected in the area of the worker jobs for dataset-related (intents, entities) tasks, specifically their connection to the database. We will update the issue as more information becomes available. In the meantime, we recommend to not create new bots, versions, or do forking operations as these would fail. We apologize for the inconvenience.
Posted Sep 25, 2020 - 22:04 CEST
Investigating
We are currently investigating an issue related to bot creation, bot forking, and version creation. These operations currently fail for intent- and entity-related data, leaving the bot / bot version in a non-working state. We are analyzing the issue and will update this incident with further information as it becomes available.

Please note that the runtime is *not* impacted by this incident and productive bots continue to work as expected.
Posted Sep 25, 2020 - 21:07 CEST
This incident affected: US10 ([US10] Design Time).